9 1.1K
1 likes
posted by robinsenny in Introductions

USB not working

Hi,

I have a Toshiba Satellite P855-S5200. After using a backup hard drive (Apricorn EZ-Gig) (assumed timing) all the 3.0 USB sockets have failed. The drive was powered by the USB. The Win10 device manager shows that the USB has a problem. It is using the Microsoft driver and I tried to change it to the Toshiba Win7 or 8.1 64 bit driver but Windows won't "take it". There wasn't any smoke, smell or otherwise but not even a mouse will work on any of them. Did Toshiba have a problem with this?

Please help.

I didn't find the right solution from the Internet.

Thanks!

What are your thoughts? Sign Up or Log In

bienn05 - 0 points - 1 year ago
Have you tried other USB? Try buying a brand new and test it. If it failed I think there is a hardware problem or PC problem.
Martinsx - 1 point - 1 year ago
Well, buying a whole new USB would solve the problem without any doubt. I have had to change mine a few times till I was made to understand that changing the cord would be a good way to taking care of the problem as well.
fishbate - 0 points - 1 year ago
Check your device manager and see if there's a notification on the USB hardware. Its a yellow icon besides an hardware category. Usually this means that the driver for the hardware is not compatible or not available. You just need to search for compatible drivers for the OS either manually or automatically.
Martinsx - 0 points - 1 year ago
The problem might be from the USB cord which you are trying to use on your laptop computer. I have had such experience before and I jumped into the conclusion that my system USB is damaged until I was advised to try getting a new USB CABLE OR CORD and everything worked perfectly. So, I would recommend trying to get a new USB CABLE.
kinja90 - 1 point - 1 year ago
Try to plug in another in another thumb drive on your computer. If it works, then there's an issue with your hard drive.

You can also try to un-check the "Allow the computer to turn off this device to save power".
To do that, press and hold Win + R keys then type devmgmt.msc then hit Enter. Then expand "Universal Serial Bus controllers". Double click the " USB Root Hub" device in the list. Click the "Power Management" tab. Then uncheck "Allow the computer to turn off this device to save power".

Another thing to do is to try download Driver Easy program. It will automatically detect any outdated drivers and download the latest version. You can download it at : http://www.drivereasy.com/DriverEasy_Setup.exe
Gilgamesh - 1 point - 1 year ago
Maybe the USB is not compatible into your PC? Also try other USB because there is a possibility that it is broken. That's all.
Martinsx - 1 point - 1 year ago
Most times, it's the USB port or cord that makes it hard to be recognized. I have had several problems with mine and was made to understand it's what was wrong. So, anytime mine starts giving me troubles, I would just change the cord.
jeffreyjose48 - 1 point - 1 year ago
When my USB is not working, I believe it was affected by viruses. I have USB that I plug into our smart television. When I tried to see the files you would not see anything on the television. Its because of viruses.
Corzhens - 1 point - 10 months ago
I am sorry to say that the USB itself has the problem that you are lucky if you can still use it after formatting. But you may still try to check it with other computers running on a different operating system otherwise formatting is your last recourse. It happened to our USB one time when we used it to print in a cyber shop. When it returned, there were so many folders that couldn't be accessed. I don't know if it was hit by a virus but our anti-virus said the USB is clean. After checking the USB with other computers, I surrendered and had it formatted. Now I am still using the same USB that I hope would not repeat the problem.
Join the discussion make a post!
Latest Posts